My Humax Forum » Profile

Biggles

User Activity

Recent Replies

  1. 9300T screen ratio suddenly changed User last replied: 5 hours ago. No replies since.
  2. 9300T drive failed - best HDD replacement User last replied: 1 week ago. Most recent reply: 1 week ago
  3. Series link quirk. User last replied: 2 weeks ago. Most recent reply: 2 weeks ago
  4. replacing hard drive and where to buy one User last replied: 3 weeks ago. Most recent reply: 2 weeks ago
  5. EPG not populated after second day User last replied: 3 weeks ago. No replies since.
  6. Remote control not responding User last replied: 4 weeks ago. Most recent reply: 3 weeks ago
  7. 9300T reboots every 5 mins (exactly) User last replied: 4 weeks ago. Most recent reply: 3 weeks ago
  8. PVR 9200 locked on station? User last replied: 1 month ago. No replies since.
  9. Help please - 9300T needs new hard drive User last replied: 2 months ago. Most recent reply: 1 month ago
  10. NEW 9200T wont record User last replied: 3 months ago. Most recent reply: 3 months ago
  11. display User last replied: 3 months ago. No replies since.
  12. The 9200 --:-- clock problem. User last replied: 3 months ago. No replies since.
  13. PVR 9150T lost sound User last replied: 4 months ago. Most recent reply: 4 months ago
  14. Losing end of recordings User last replied: 4 months ago. Most recent reply: 4 months ago
  15. Talktalk YouView box and my old Humax 9200T User last replied: 6 months ago. No replies since.
  16. PVR-9200T clone drive? User last replied: 6 months ago. Most recent reply: 6 months ago
  17. Missed recordings User last replied: 6 months ago. Most recent reply: 6 months ago
  18. Incorrect EPG User last replied: 7 months ago. No replies since.
  19. How to upgrade software User last replied: 8 months ago. No replies since.
  20. PVR-9300T User last replied: 8 months ago. No replies since.
  21. no sound User last replied: 9 months ago. Most recent reply: 9 months ago
  22. Remote Range?? User last replied: 9 months ago. No replies since.
  23. Recording Stops after 1 Minute User last replied: 9 months ago. Most recent reply: 9 months ago
  24. Can't play recorded programme User last replied: 9 months ago. No replies since.
  25. 9300T - Jumps during playback User last replied: 9 months ago. Most recent reply: 9 months ago

Topics Started

  1. The 9200 --:-- clock problem. Started: 3 years ago Most recent reply: 3 months ago.
  2. Big-les from DS Started: 3 years ago Most recent reply: 3 years ago.