My Humax Forum » Freesat HD » HB 1000S, 1100S

Topic — Add New » Read
HB1000s - no channel4 on demand app available (9 hours ago, 2 posts, 23 views)
Started by: Roadiesean with 2 posters
latest post by
jdlfreetime
7 hours ago
hb-1000s issues (2 weeks ago, 7 posts, 138 views)
Started by: Pauly_j with 2 posters
latest post by
Pauly_j
6 days ago
Is Software Required to see content in windows? (4 mnths ago, 2 posts, 219 views)
Started by: BiyM37St0p-1 with 2 posters
latest post by
Luke
4 mnths ago
HB 1000S no internet connection? (5 mnths ago, 34 posts, 1883 views)
Started by: eastwater with 17 posters
latest post by
martinrowlands
5 mnths ago
One for All Remote and the 1100S (6 mnths ago, 15 posts, 688 views)
Started by: RichardH with 3 posters
latest post by
RichardH
6 mnths ago
HDR1000S replaces Sky Q - maybe? (7 mnths ago, 4 posts, 308 views)
Started by: derekn with 2 posters
latest post by
derekn
7 mnths ago
Internet connection (8 mnths ago, 4 posts, 235 views)
Started by: SPD54 with 2 posters
latest post by
Martin Liddle
8 mnths ago
Sudden Death (8 mnths ago, 9 posts, 351 views)
Started by: Edislaw with 4 posters
latest post by
jdlfreetime
8 mnths ago
HB-1100S external hard drive (9 mnths ago, 2 posts, 243 views)
Started by: slls1961 with 2 posters
latest post by
Martin Liddle
9 mnths ago
Migrate recordings to new 1TB external drive (9 mnths ago, 1 posts, 259 views)
Started by: slls1961 with no replies
latest post by
slls1961
9 mnths ago
Cannot view Ch4 HD since it moved from 126 to 104 (9 mnths ago, 1 posts, 592 views)
Started by: Fargon with no replies
latest post by
Fargon
9 mnths ago
USB Flash Drive not visible HDR 1100S (10 mnths ago, 3 posts, 229 views)
Started by: mexicano with 2 posters
latest post by
mexicano
10 mnths ago
HUMAX HB1000s (10 mnths ago, 3 posts, 306 views)
Started by: Nickkdx with 2 posters
latest post by
Nickkdx
10 mnths ago
HDR 1100s will not boot, no lights (2 years ago, 4 posts, 747 views)
Started by: Rice pudding with 4 posters
latest post by
H_o_p_p_a
11 mnths ago
SD channels disapearing (1 year ago, 5 posts, 354 views)
Started by: Bobmoore with 3 posters
latest post by
Bobmoore
1 year ago
Gbnews subtitles (1 year ago, 5 posts, 505 views)
Started by: Bobmoore with 3 posters
latest post by
Martin Liddle
1 year ago
Humax 1100S - NO SIGNAL (1 year ago, 1 posts, 373 views)
Started by: ColinA with no replies
latest post by
ColinA
1 year ago
1100s remote control (1 year ago, 3 posts, 344 views)
Started by: markbsac with 2 posters
latest post by
markbsac
1 year ago
Programming remote? (1 year ago, 16 posts, 1553 views)
Started by: cobbler with 4 posters
latest post by
cobbler
1 year ago
Unable to connect to the Internet. (1 year ago, 2 posts, 348 views)
Started by: Frustrated111 with 2 posters
latest post by
RTWoddy
1 year ago

New Topic in this Forum

You must log in to post.