My Humax Forum » Tags » picture

Topic — Add New » Posts Last Poster
black band near top of screen
By wren55 in forum: HDR 1000/1010/1100S
8 Last reply by
grahamlthompson
3 months ago
9300T PICTURE PROBLEM
By Twizzle in forum: PVR 9150T, 9200T, 9300T
3 Last reply by
Twizzle
11 months ago
No video, not changing channels
By aciddad in forum: FVP 4000T, FVP 5000T
1 Last reply by
aciddad
2 years ago
FVR-4000T screen extents
By humax4000t_user in forum: FVP 4000T, FVP 5000T
14 Last reply by
Richard67
3 years ago
HDR-1100S screen has gone Pink with No Sound
By Geggsy125 in forum: HDR 1000/1010/1100S
7 Last reply by
Faust
3 years ago
HDR-2000T frequent picture & sound breakup
By gallopinhairpin in forum: HDR 1800T/2000T
28 Last reply by
Faust
3 years ago
Picture break-up issues
By edrch in forum: HDR FOX T2
3 Last reply by
damian
4 years ago
Strange Display Problem
By jazza in forum: PVR 9150T, 9200T, 9300T
4 Last reply by
jazza
5 years ago
9200T poor picture quality (CRT tv)
By alan997 in forum: PVR 9150T, 9200T, 9300T
5 Last reply by
Biggles
6 years ago
Picture corrupting on recordings
By bigdyl69 in forum: FOXSAT HDR
5 Last reply by
bigdyl69
6 years ago
picture breakup
By allan.flo in forum: HDR FOX T2
10 Last reply by
allan.flo
6 years ago
No picture when switching on
By sallyann16 in forum: HDR FOX T2
6 Last reply by
grahamlthompson
7 years ago
Recorded Picture Display
By Gallimaufry in forum: PVR 9150T, 9200T, 9300T
3 Last reply by
Gallimaufry
7 years ago

RSS link for this tag.

Add New Topic

You must log in to post.