My Humax Forum » Freesat HD » HB 1000S/1100S

HB 1000s will not turn on

(10 posts)
  1. User has not uploaded an avatar

    drumlerry

    new member
    Joined: Oct '17
    Posts: 4

    offline

    Hi
    My first post in this forum. My HB 1000s will not turn on.

    I've tried unplugging from mains, waiting a few minutes and then switching on power again. The red standby light does not come on with either the remote or by pressing button at bottom front left.
    The unit was purchased in late 2014 and has not been used often.
    Wouls appreciate any help with this

    Tue 17 Oct 2017 20:00:34 #1 |
  2. REPASSAC

    REPASSAC

    special member
    Joined: Mar '11
    Posts: 3,334

    offline

    Is the power supply one with the led on it and if so, does it come on?

    Wed 18 Oct 2017 7:00:40 #2 |
  3. User has not uploaded an avatar

    drumlerry

    new member
    Joined: Oct '17
    Posts: 4

    offline

    Hi

    There is no led on the power supply. The name on the power supply is Ktec.
    I've also tried another power supply (from my laptop) but unit will not turn on. The Humax box has very little use - perhaps once per month

    Photo attached

    Wed 18 Oct 2017 8:40:10 #3 |
  4. User has not uploaded an avatar

    drumlerry

    new member
    Joined: Oct '17
    Posts: 4

    offline

    photo of Humax box that won't turn on

    Attachments

    1. small-IMG_20171018_093000723.jpg (93.1 KB, 9 downloads) 1 month old
    Wed 18 Oct 2017 8:42:20 #4 |
  5. User has not uploaded an avatar

    patsy

    senior member
    Joined: Sep '16
    Posts: 55

    offline

    I know this may sound silly but I experienced this twice. Firstly when you turn the box on. Leave it five minutes for it to register. Then I found that by pressing the STB button or even the TV button it started. Hopefully the HI tech guys will sort you out if this doesnt work.

    Wed 18 Oct 2017 12:04:26 #5 |
  6. REPASSAC

    REPASSAC

    special member
    Joined: Mar '11
    Posts: 3,334

    offline

    Suggestions:

    1. Disable HDMI-CEC on the TV (See FAQ's for Brand names for this). Then reboot TV.
    2. Mains Power off for 10 minutes.
    3. Mains power on - Leave 10 minutes.
    4. Try starting it using front panel

    Wed 18 Oct 2017 12:24:36 #6 |
  7. User has not uploaded an avatar

    drumlerry

    new member
    Joined: Oct '17
    Posts: 4

    offline

    Hi
    Thanks for suggestions
    Tried all those but Humax HB1000s will not turn on

    Wed 18 Oct 2017 14:14:33 #7 |
  8. User has not uploaded an avatar

    toonbager

    new member
    Joined: Nov '17
    Posts: 2

    offline

    Hi

    I would be very interested to know how you progressed with your Humax HB-1000S, as mine stopped working last night also i.e. will not power on. Did you manage to get it repaired?

    Had mine for about 2 and 1/2 years (therefore out of warranty), then last night whilst watching a TV recording picture started flickering / breaking up and making weird electronic interference noises and shortly there after stopped working all together.

    I tried using a working power plug from another working Humax pvr box, still no joy. Assuming it must be an internal power supply component failure.

    As I have about a years worth of TV recordings on the portable hard drive, which I believe can only be played using the broken Humax, I am wondering if I should try getting it repaired (if repairable) or accept I've lost all my recordings.

    Any advice??

    Sun 12 Nov 2017 11:25:58 #8 |
  9. black knight

    black knight

    senior member
    Joined: Dec '14
    Posts: 70

    offline

    Open it up and see if there's any bulging or leaking capacitors anywhere.

    Naturally don't do this while it's plugged in!

    Sun 12 Nov 2017 19:30:45 #9 |
  10. User has not uploaded an avatar

    toonbager

    new member
    Joined: Nov '17
    Posts: 2

    offline

    Opened it up as suggested with no sign of any visible bulging or leaking capacitors anywhere.

    Any the wiser? Suggestions much appreciated.

    Mon 13 Nov 2017 19:12:52 #10 |

RSS feed for this topic

Reply

You must log in to post.