My Humax Forum » Freeview HD » HDR 1800T, 2000T

Humax HDR 2000T - Data Storage greyed out

(1 post)
  1. User has not uploaded an avatar


    new member
    Joined: May '24
    Posts: 1


    Hi there.

    We've owned a Humax HDR-2000t for several years now and it's been working perfectly until last week. My partner went to view her recorded programmes and nothing came up (the menu just closed down and back to the live TV).

    Not knowing much about these devices, I had a dig around in the Settings and found that 'Data Storage' was greyed out.

    I took the cover off and the drive was still spinning up. Thinking it was just a hard drive issue, I got a standard 2.5" Seagate 500gb (non-SSD) drive from work; formatted it to NTFS and replaced the old one. I fired up the Humax and entered the Settings menu again but 'Data Storage' was still greyed out.

    I found the factory reset option and checked the 'Format Drive' box. It sat there for about 4 hours saying 'Processing' but after that disappeared, I checked 'Data Storage' again and it was still greyed out.

    I tried formatting the drive to EXT3 as I'd seen mention that this might help and also tried again with the original 3.5 drive; instigating a factory reset with drive formatting both times but I'm still in the same situation with the greyed out data storage and the inability to record etc.

    At this point now, I'm thinking it's likely not a drive issue but I have no idea how to rectify the problem so any advice would be appreciated.

    Thanks for reading.

    | Mon 13 May 2024 13:13:23 #1 |

RSS feed for this topic


You must log in to post.