My Humax Forum » Freeview HD » FVP 4000T, 5000T

Wont' turn off - only volume buttons working

(2 posts)
  1. User has not uploaded an avatar

    Mary Anne

    new member
    Joined: Nov '16
    Posts: 1


    I think I have the model right.

    When we bought the Mocha, it came with the RM-L08 remote. It never worked. it was a fight to get it to respond when the buttons were pushed, it only worked if pushed in the upper portion of some buttons, the side on the others. We really should have returned it, but we had a new aerial and the installer brought his along, a RM-L03. It was totally responsive and we ordered one of them. All was good for a few months.

    Last night,m all of a sudden the picture went. The sound was fine but the screen was black. The other Smart TV apps (like Netflix and NOW TV) worked fine, just the Humax display was dark.

    Neither remote worked. On both, when pressing the on button, it lit up but nothing happened. Even pressing the button on the box, to switch it to standby, did nothing. The channel would not change, the guide would not come up, NOTHING but volume up/down.

    New batteries make no difference (didn't expect they would but I had to try)

    I have now unplugged it a left it unplugged to see if it will reset itself.

    Any thoughts? What is the process for sorting it out?

    Admin edit: moved to correct forum.

    | Thu 26 Jan 2017 11:15:43 #1 |
  2. User has not uploaded an avatar


    special member
    Joined: Jan '12
    Posts: 597


    Hi Mary Anne,

    it's anybodys guess what will happen when plugged back in. I'd imagine the Mocha has simply crashed like most PC's do when left on 24/7 without a reboot once in a while.
    The Mocha will have got slower and less responsive until it reaches a point where it freezes. A proper reboot, i.e. unplugging from the mains or switching off at the mains for 10 - 30secs or so is useful every now and again, a good time to do this is after a software/firmware update. You don't need to leave it unplugged for longer for it to reset.

    If it doesn't spring back into life, check all the connections, mainly hdmi as these can come loose and remember the Mocha can take a few minutes to start up after switching back on, there'll just be a blue or red LED for a minute or two with the Mocha seemingly doing nothing.

    If the Mocha appears to be broken I'd advise contacting where you bought it from or Humax customer service for further advice and a replacement if necessary.

    A friendly forum moderator should move this to the fvp4000t section in due course and welcome to the forum.

    | Thu 26 Jan 2017 12:46:33 #2 |

RSS feed for this topic


You must log in to post.