My Humax Forum » Freeview HD » FVP 4000T, 5000T

Humax Freeview play No power.

(2 posts)
  1. User has not uploaded an avatar

    flower01

    new member
    Joined: Apr '20
    Posts: 1

    offline

    My apologies if I should not have posted here. We have had our FVP 4000T for some time and it has been brilliant. Between Lunch time when we viewed a recorded program, and early evening; there was no power. We tried other electrical outlets with no success. All other components that the Humax was connected to were fine.
    Before I consider replacing the power plug is there anything else worth trying please.

    Mon 6 Apr 2020 9:19:41 #1 |
  2. grahamlthompson

    grahamlthompson

    special member
    Joined: Feb '11
    Posts: 11,442

    online

    flower01 - 58 mins ago  » 

    My apologies if I should not have posted here. We have had our FVP 4000T for some time and it has been brilliant. Between Lunch time when we viewed a recorded program, and early evening; there was no power. We tried other electrical outlets with no success. All other components that the Humax was connected to were fine.
    Before I consider replacing the power plug is there anything else worth trying please.

    Welcome To our Forum.

    First thing to try is booting with the power switch top right on the unit.

    If it now comes on change the batteries in the remote control. Before using it again push the top left button on the remote to make sure the remote is set to control the box and not the AV control function.

    If that doesn't work then

    Pull out the thin power cable from the rear of the unit. Leave it out for a minute or two. The unit should appear to start up for a short period as it resets the clock and go back into sby. Now try booting it with power button on the remote and/or the top power button.

    Mon 6 Apr 2020 10:24:13 #2 |

RSS feed for this topic

Reply

You must log in to post.