Picture breaking and up stuttering « My Humax Forum

My Humax Forum » Freeview HD » HD FOX T2

Picture breaking and up stuttering

(2 posts)
  1. User has not uploaded an avatar

    Dwards

    new member
    Joined: Sep '16
    Posts: 1

    offline

    Hello

    My topic is similar to others but not exactly.

    I have had the T2 about 4 or 5 years, and have been very happy with it, using it daily including recording.

    In the last month its started breaking up when watching recordings and live telly. I haven't changed anything, and telly reception alone is fine, and that comes through aerial connected to T2.

    I contacted Humax and they sent me instructions on how to manually rescan, which i did - still the same problems. However, it does seem to come and go a little, some channels seem ok, and some recordings seem fine too. It could be just HD channels that do it, but i'm not sure.

    I live quite close to crystal palace, and get about 60% signal strength and 100% quality. The humax is connected to a communal aerial, and someone could have tampered with it, but telly reception fine.

    If its just given up the ghost that's fine - i've had my moneysworth, but wanted to check in case i bought a new one and it has same problems

    Any ideas?

    Thanks

    Wed 7 Sep 2016 11:59:06 #1 |
  2. andyfras

    andyfras

    senior member
    Joined: Nov '15
    Posts: 73

    offline

    I suspect that it needs some new PSU capacitors. PM me for details.

    Wed 7 Sep 2016 12:28:27 #2 |

RSS feed for this topic

Reply

You must log in to post.