My Humax Forum » Freeview HD » HD FOX T2

Topic — Add New » Read
  How to videos (7 years ago, 3 posts, 1803 views)
Started by: Barry with 2 posters
latest post by
Barry
7 years ago
Remote control - confused if 3 or 4 digit codes (8 years ago, 11 posts, 14352 views)
Started by: Barry with 8 posters
latest post by
Luke
4 mnths ago
Delay before channels appear (4 mnths ago, 3 posts, 127 views)
Started by: ronlowe with 2 posters
latest post by
ronlowe
4 mnths ago
Recordings cutting short on HD-FOX T2 (4 mnths ago, 2 posts, 70 views)
Started by: Lorraine with 2 posters
latest post by
Martin Liddle
4 mnths ago
Can't reset Humax Freeviw Box (10 mnths ago, 14 posts, 1 views)
Started by: Gerrymac with 4 posters
latest post by
Gerrymac
10 mnths ago
Folders (6 years ago, 6 posts, 808 views)
Started by: Poisonivy with 5 posters
latest post by
Martin Liddle
1 year ago
All my reservations have disappeared! (1 year ago, 11 posts, 718 views)
Started by: prairiegirl with 5 posters
latest post by
prairiegirl
1 year ago
Where is BBC4 HD? (1 year ago, 30 posts, 3669 views)
Started by: Saralikesradio with 12 posters
latest post by
Faust
1 year ago
Failed recordings (1 year ago, 1 posts, 362 views)
Started by: Rick m with no replies
latest post by
Rick m
1 year ago
How to map a humax drive to a pc (1 year ago, 6 posts, 750 views)
Started by: Bobmoore with 3 posters
latest post by
Bobmoore
1 year ago
RM-F04 Remote Control unresponsive (1 year ago, 1 posts, 367 views)
Started by: Celadon with no replies
latest post by
Celadon
1 year ago
HD FOX T2 blank screen. (2 years ago, 8 posts, 733 views)
Started by: John Shaft with 3 posters
latest post by
John Shaft
2 years ago
Programmes apparently recorded but not listed. (2 years ago, 1 posts, 524 views)
Started by: Chickpea57 with no replies
latest post by
Chickpea57
2 years ago
What to do (2 years ago, 6 posts, 524 views)
Started by: Socky with 2 posters
latest post by
grahamlthompson
2 years ago
Box 'sees' USB stick but won't use it (2 years ago, 6 posts, 1069 views)
Started by: alan997 with 3 posters
latest post by
alan997
2 years ago
TV Portal stopped working (5 years ago, 80 posts, 18538 views)
Started by: peterh0001 with 23 posters
latest post by
mactoshb
3 years ago
Failed to track programme (3 years ago, 13 posts, 1281 views)
Started by: tombar with 3 posters
latest post by
tombar
3 years ago
iPlayer crashes/system flush/CF/can't record (3 years ago, 1 posts, 767 views)
Started by: IainBathers with no replies
latest post by
IainBathers
3 years ago
Green Screen (3 years ago, 4 posts, 1385 views)
Started by: MrFraggle with 3 posters
latest post by
MrFraggle
3 years ago
Picture breaking and up stuttering (3 years ago, 2 posts, 679 views)
Started by: Dwards with 2 posters
latest post by
andyfras
3 years ago
Detecting new Channels? (3 years ago, 3 posts, 774 views)
Started by: colin1951uk with 2 posters
latest post by
colin1951uk
3 years ago

New Topic in this Forum

You must log in to post.