Subtitles on iplayer « My Humax Forum

My Humax Forum » Welcome!

Subtitles on iplayer

(5 posts)
  1. grahamlthompson

    grahamlthompson

    special member
    Joined: Feb '11
    Posts: 9,943

    offline

    Can anyone get subtitles on iplayer. Watching Dr Who the s under the playback toggles subtitles/off but even when on on my box none appear.

    Sat 27 Oct 2018 9:18:20 #1 |
  2. User has not uploaded an avatar

    A1944

    special member
    Joined: Dec '17
    Posts: 190

    offline

    Copied from my AVForums reply:

    I just tried the same thing, but with Blue Planet 2, and the subtitles worked fine.

    There is one slightly confusing point though. When the subtitles are running, under the S button, when it is highlighted, it says "Subtitles Off", meaning that "Off" is what will happen if the button is pressed. When they are not running, it just says "Subtitles".

    Sat 27 Oct 2018 10:13:09 #2 |
  3. grahamlthompson

    grahamlthompson

    special member
    Joined: Feb '11
    Posts: 9,943

    offline

    Just tried Blue Planet 2 S1 - Ep 1. Still no subtitles. That seems odd, normally when it says subtitles presumably it's a toggle when it says subtitles I would have thought they were on. Very strange setting to off makes them work.

    Sat 27 Oct 2018 11:20:25 #3 |
  4. User has not uploaded an avatar

    Malcy93

    new member
    Joined: Oct '17
    Posts: 1

    offline

    Sorry to hijack this thread but came here as my dad is having exactly the same problem with his Humax Freeview Play Box.

    He thinks there was a software update of the BBC iPlayer app last week which has deleted the subtitling option. Had been on holiday for 2 weeks and was working okay before he went away.

    Definitely seems a fault with the iPlayer app on the Humax as the app on his Samsung TV still plays subtitles okay.

    Wed 31 Oct 2018 19:31:48 #4 |
  5. grahamlthompson

    grahamlthompson

    special member
    Joined: Feb '11
    Posts: 9,943

    offline

    Malcy93 - 18 minutes ago  » 
    Sorry to hijack this thread but came here as my dad is having exactly the same problem with his Humax Freeview Play Box.
    He thinks there was a software update of the BBC iPlayer app last week which has deleted the subtitling option. Had been on holiday for 2 weeks and was working okay before he went away.
    Definitely seems a fault with the iPlayer app on the Humax as the app on his Samsung TV still plays subtitles okay.

    Subtitles do work on a 5000T in iplayer. The way to switch them on is very confusing. While viewing press pause and move to the s under the progress bar. Click on the S confusingly the prompt changes to a subtitles off ignore the SUB button the remote whixh only works for live channels. This also works for the other in demand channels except the ITV-hub. So far only found subtitles on ITV-Hub work using a PC.

    Welcome to our forum.

    Wed 31 Oct 2018 19:55:57 #5 |

RSS feed for this topic

Reply

You must log in to post.