My Humax Forum » Freeview HD » FVP 4000T, 5000T

Replacement remote

(9 posts)
  1. User has not uploaded an avatar

    vexillia

    member
    Joined: Jul '17
    Posts: 19

    offline

    Currently our RM-08 has developed, and is developing, a few dodgy buttons. Mainly On/Off.

    Is there a fix or do I need a replacement? If the latter what's the best one and where do I buy one from.

    Thanks.

    | Fri 14 May 2021 13:51:17 #1 |
  2. User has not uploaded an avatar

    stro

    junior member
    Joined: Oct '14
    Posts: 8

    offline

    I think you can get them from Humax direct I have one I bought a new one last week for my Aura but it wasn't the remote at fault it is a RM 07 though. I paid £30 inc del I note yours is(RM 08) I don't know the difference. If you are interested £20 posted

    | Fri 14 May 2021 14:51:28 #2 |
  3. User has not uploaded an avatar

    Martin Liddle

    special member
    Joined: Feb '11
    Posts: 3,689

    online

    I bought an RM-L08 from https://www.remote-controls-shop.co.uk/catalogue/humax/fvp5000t/ (the original rather than the cheaper replacement option) and as far as I can tell it is a genuine Humax remote.

    | Fri 14 May 2021 19:20:40 #3 |
  4. User has not uploaded an avatar

    vexillia

    member
    Joined: Jul '17
    Posts: 19

    offline

    Thanks for the help. In the end I bought a cheap replacement via amazon for £11.99 inc. delivery - http://www.amazon.co.uk/gp/product/B076F36SXP

    Arrived today. All I had to do was put some batteries in (not included). Works well but does need to be pointed at the Humax.

    The layout isn't really that different. There are the same blocks of buttons as the RM-08; the only difference is that the blocks are in a different order.

    | Tue 18 May 2021 21:52:55 #4 |
  5. User has not uploaded an avatar

    A1944

    special member
    Joined: Dec '17
    Posts: 724

    offline

    I have just got a new RM-L08 remote because the buttons were getting tricky to use.

    I would like, once I have checked it out, to open up the old one to try and clean the contacts, or whatever. I have searched unsuccessfully for instructions on opening it, which I am sure I have seen somewhere here. Can anyone point me at a thread which tells me please.

    | Wed 19 May 2021 14:08:46 #5 |
  6. User has not uploaded an avatar

    Fyl

    member
    Joined: Nov '16
    Posts: 16

    offline

    Firstly thanks to Martin for the link, I too have now replaced my irritating intermittent RM-L08.

    The link to the thread for servicing the RM-L03 is here, but it is close enough to apply to the 08:
    https://myhumax.org/forum/topic/disassemble-rm-l03-remote-control

    However, I found with my RM-L08 that the functions that were the worst are micro-switches and not contact pads, so were unserviceable.

    | Thu 20 May 2021 9:31:11 #6 |
  7. User has not uploaded an avatar

    SSThing

    special member
    Joined: Nov '15
    Posts: 855

    offline

    A1944 - 19 hours ago  » 
    I have just got a new RM-L08 remote because the buttons were getting tricky to use.
    I would like, once I have checked it out, to open up the old one to try and clean the contacts, or whatever. I have searched unsuccessfully for instructions on opening it, which I am sure I have seen somewhere here. Can anyone point me at a thread which tells me please.

    You need to insert a very fine flat blade screwdriver into the thin gap on the side between the silver top and black case and twist/pry the two halves apart. Once you get it started, it comes apart easily but it's almost inevitable that you will end up with pry marks in the plastic.
    When it is apart, clean everything with a cotton bud and a non-solvent cleaning fluid (I use spectacle cleaner).
    When you put it back together, make sure you put the central (OK/L/R/UP/DOWN) pads and mech in the right orientation (they have locating tabs).

    | Thu 20 May 2021 9:49:40 #7 |
  8. User has not uploaded an avatar

    A1944

    special member
    Joined: Dec '17
    Posts: 724

    offline

    I managed to find a useful dismantling and servicing guide for the RM-L08 in this YouTube video:

    https://www.youtube.com/watch?v=fHSbpXYa1Ao

    Opening it was a touch of "brute force and ignorance" using the large blade on an old Swiss Army Knife, which I had in a drawer, but got it apart eventually without hurting myself.

    Unlike the man in the video, my issues were not with the central buttons, but those at the top - power, pause, play etc., so I left the stick-on panel undisturbed and concentrated on the black pads on the rubber strip. They had noticeable amounts of accumulated "grease" which was something I had seen before.

    So I gave the PCB a gentle wipe with a dry tissue and cleaned the black pads individually using dry cotton buds until they were no longer shiny. That seems to have sorted it (for now, at least), so I have two apparently serviceable remotes.

    -------

    Edit: Thanks SSThing, I had already got into it by the time you replied, but I have been busy with housework since then, so didn't see your advice. Not sure about the silver part you mentioned, but maybe that is an earlier version, but anyway I managed it.

    | Thu 20 May 2021 10:25:30 #8 |
  9. User has not uploaded an avatar

    SSThing

    special member
    Joined: Nov '15
    Posts: 855

    offline

    Silver bit is on my L03, hadn't realised that the L08 was all black.

    | Thu 20 May 2021 10:33:04 #9 |

RSS feed for this topic

Reply

You must log in to post.