My Humax Forum » Freeview HD » Aura UHD

Cannot add apps

(3 posts)
  1. User has not uploaded an avatar

    Zebra

    new member
    Joined: Jul '24
    Posts: 2

    offline

    Hi, I'm new to the Aura...Have tried to download a basic internet browser, Discovery plus, and rugbypass tv - all available in the more apps section. All of them stopped at pending for ages, so I gave up. Android home button does nothing.

    Is this normal? (Using wired cat 6 virgin fibre network and no issue with running iplayer etc?)

    | Tue 9 Jul 2024 15:36:18 #1 |
  2. User has not uploaded an avatar

    VitaminD

    special member
    Joined: Mar '22
    Posts: 139

    offline

    You should be able to download and install any apps that are available via the Google Play Store and the Apps button on the remote.
    Have you set up your Google account on the Aura?

    If you are already able to stream the iPlayer that would suggest there is nothing wrong with your internet connection.

    If you are using an ethernet cable for internet connection then go into the Freeview button > Settings > Network & Internet and make sure WiFi is turned off, just in case that is the issue.
    Then click down further and confirm that under Ethernet it is showing connected.

    If you are able to use a WiFi connection rather than Ethernet unplug the Ethernet cable and switch WiFi on and set that up and see if that helps resolve the issue.

    Occasionally when updating apps I have encountered it hanging while 'pending' if after a minute it is still pending I will power down the Aura (long press of the power button on the remote) and wait 5 minutes before powering up and that usually clears it.

    | Tue 9 Jul 2024 17:48:10 #2 |
  3. User has not uploaded an avatar

    Zebra

    new member
    Joined: Jul '24
    Posts: 2

    offline

    Thank you Vitamin D - just the boost I needed. So, switched on the box and tv to follow your instructions, and opening screen was the basic android tv set up screen, which I went through (again) confirming google account details already loaded etc. After this process, I confirmed ethernet connection and turned wifi off.

    Had to play around a bit, but finally got into the apps, and both discovery+ and rugbypass loaded straightaway! Then went back to tv, but although guide was there, no picture for the few channels I tried. Switched on and off, and seems ok now. Android home button now works!

    Having come from virgin box, the aura seems a bit dated and inconsistent, but I seem to have what I need now. Thanks again.

    | Wed 10 Jul 2024 11:37:03 #3 |

RSS feed for this topic

Reply

You must log in to post.