My Humax Forum » Freeview HD » FVP 4000T, FVP 5000T

FVP 4000T Remote Control

(31 posts)
  1. clairehen

    clairehen

    member
    Joined: Oct '16
    Posts: 11

    offline

    Surprised not to find complaints about the RM-L08 remote control. It has great direct keys for recordings, Netflix and On Demand, but is very poor response-wise. Changing the batteries had no effect and it often takes several tries before working. I thought it might jut be a blip but outside of this forum I've come across a number of moans across the internet. I finally bit the bullet and purchased a compatible RMC3056. Took delivery today and it responds first time, every time. It's different layout and doesn't have a recordings button, but the Apps button replaces On Demand, there's a Netflix button, a Home button and you can work out the rest easily. This is not an advert but a heads up. A great pity that Humax fell at this hurdle. The Humax remotes are also extremely expensive so should be fit for purpose. Any thoughts?

    Tue 18 Apr 2017 19:34:53 #1 |
  2. Luke

    Luke

    special member
    Joined: Apr '11
    Posts: 874

    offline

    clairehen - 34 minutes ago  » 
    Surprised not to find complaints about the RM-L08 remote control.

    Here is a link to a thread that mentions other unloved FVP-4000T remotes but also some that are better
    https://myhumax.org/forum/topic/remote-control-4

    Tue 18 Apr 2017 20:12:02 #2 |
  3. User has not uploaded an avatar

    Victoria7500

    new member
    Joined: Apr '17
    Posts: 2

    offline

    If your Humax is still under warranty it's worth contacting them about this. 

    I also found the remote terrible, in particular the OK button and the surrounding directional arrows rarely responded even to me pressing as hard as I could (and when they finally did they would then register several presses and skip past what I was trying to get to - incredibly frustrating!) Was going to buy a universal one but after reading a couple of other threads on here where people had the same issue and seeing it mentioned that it was meant to be solved with later batches, I decided to try a warranty claim first. 

    Emailed them, got a response a couple of days later asking for a copy of my receipt and my address, and they sent me a new one no bother, arrived through the letterbox a few days later, all very painless. It looks identical to the original but the difference is night and day, all buttons now respond to normal pressure each and every time, it really feels like a whole different Freeview box. Hopefully it'll last as others seem to have seen issues develop after a few months, but my original remote was certainly bad from the start.

    Maybe a bit late for you since you've already bought a new remote, but it would always give you a spare, and hopefully it'll help anyone else who comes upon this thread with the same problem.

    Sun 23 Apr 2017 8:40:55 #3 |
  4. User has not uploaded an avatar

    mrmightyfine

    junior member
    Joined: Jan '17
    Posts: 5

    offline

    I had remote control issues but thought it was the box. Humax customer support said a few remotes were faulty and they improved them and they're now fine, they are the same number. I was sent the improved remote and now everything is just great

    Sun 23 Apr 2017 20:22:39 #4 |
  5. User has not uploaded an avatar

    Harters

    member
    Joined: Mar '17
    Posts: 36

    offline

    I had the original RM-L03 black and silver remote which started playing up with the OK and arrow keys sticking to each other. No problmes with response issues with the remote.

    Did online chat and a few days later the latest remote lands on my doorstep which is like night and day quality wise and having a button to get directly to the recordings is a God send.

    Having said that, the box is still painfully slow, so I just live in hope that it may improve one day, if not I will go back to my old HDR.

    Mon 24 Apr 2017 7:17:03 #5 |
  6. RogerB

    RogerB

    special member
    Joined: Nov '15
    Posts: 246

    offline

    New RM-L08 arrived today - which is lovely. Can't find the booklet now to give me the code range to switch on/off TV - which is not lovely. Can someone please point me in the right direction? Thanks, R-

    Tue 25 Apr 2017 8:56:26 #6 |
  7. Barry

    Barry

    administrator
    Joined: Feb '11
    Posts: 8,135

    offline

  8. RogerB

    RogerB

    special member
    Joined: Nov '15
    Posts: 246

    offline

    Thank you, Barry. Swift service as usual. R-

    Tue 25 Apr 2017 9:21:15 #8 |
  9. clairehen

    clairehen

    member
    Joined: Oct '16
    Posts: 11

    offline

    Victoria7500 - 2 days ago  » 
    If your Humax is still under warranty it's worth contacting them about this. 
    I also found the remote terrible, in particular the OK button and the surrounding directional arrows rarely responded even to me pressing as hard as I could (and when they finally did they would then register several presses and skip past what I was trying to get to - incredibly frustrating!) Was going to buy a universal one but after reading a couple of other threads on here where people had the same issue and seeing it mentioned that it was meant to be solved with later batches, I decided to try a warranty claim first. 
    Emailed them, got a response a couple of days later asking for a copy of my receipt and my address, and they sent me a new one no bother, arrived through the letterbox a few days later, all very painless. It looks identical to the original but the difference is night and day, all buttons now respond to normal pressure each and every time, it really feels like a whole different Freeview box. Hopefully it'll last as others seem to have seen issues develop after a few months, but my original remote was certainly bad from the start.
    Maybe a bit late for you since you've already bought a new remote, but it would always give you a spare, and hopefully it'll help anyone else who comes upon this thread with the same problem.

    Thanks for the advice Victoria. Your first paragraph describes absolutely the problems I've been experiencing. I've emailed Humax Customer Services with my Warranty registration, so hopefully they'll respond in the next couple of days.In the meantime, RM remote continues to work well. I'll still need the original replaced because my poor husband has to go on a training course every time there's a change in technology!

    Tue 25 Apr 2017 12:11:55 #9 |
  10. RogerB

    RogerB

    special member
    Joined: Nov '15
    Posts: 246

    offline

    Has anyone found how to get the HOME function on the RM-LO8? I need to change a setting but can't figure out how to get to them. Thanks, R-

    Sat 29 Apr 2017 5:33:14 #10 |

RSS feed for this topic

Reply »

You must log in to post.