My Humax Forum » Freeview HD » FVP 4000T, 5000T

My5 problem

(55 posts)
  1. grahamlthompson

    grahamlthompson

    special member
    Joined: Feb '11
    Posts: 11,790

    offline

    fairfieldfive - 2 hours ago  » 
    I'll join the queue of frustrated Humax users (4000t for me) with Freeview Play. iPlayer takes three minutes to load, ITV more, All4 even more and My5 not at all.
    Humax talks of a 'known problem' without a timescale for fixing it.
    I have complained more formally and suggested that their product has become unfit for purpose within the terms of the Consumer Rights Act 2015 and that unless a solution is found within 'a reasonable time' I shall demand a full refund.
    Worth a punt - might just spur them into activity.

    Unless you bought it from Humax direct. You only have a claim against the retailer who sold you the box.

    | Tue 19 May 2020 13:56:51 #51 |
  2. User has not uploaded an avatar

    J_Oz

    special member
    Joined: Oct '15
    Posts: 186

    offline

    This appears to have been fixed by a software update to the Humax box in June. I think it was mentioned in smoother thread but not this one.

    | Fri 4 Sep 2020 15:34:59 #52 |
  3. grahamlthompson

    grahamlthompson

    special member
    Joined: Feb '11
    Posts: 11,790

    offline

    fairfieldfive - 3 mnths ago  » 
    I'll join the queue of frustrated Humax users (4000t for me) with Freeview Play. iPlayer takes three minutes to load, ITV more, All4 even more and My5 not at all.
    Humax talks of a 'known problem' without a timescale for fixing it.
    I have complained more formally and suggested that their product has become unfit for purpose within the terms of the Consumer Rights Act 2015 and that unless a solution is found within 'a reasonable time' I shall demand a full refund.
    Worth a punt - might just spur them into activity.

    What sofware version do you have on your box. There was a fix rolled out a while ago for this issue. ?

    | Fri 4 Sep 2020 15:41:57 #53 |
  4. grahamlthompson

    grahamlthompson

    special member
    Joined: Feb '11
    Posts: 11,790

    offline

    Latest Version is UKTFAE 1.03.52 Build date 12 Jun 2020.

    | Fri 4 Sep 2020 16:56:31 #54 |
  5. User has not uploaded an avatar

    A1944

    special member
    Joined: Dec '17
    Posts: 495

    offline

    Bear in mind that the question was asked some time before the fix came out so, although fairfieldfive has not got back, the problem may have gone away for them.

    | Fri 4 Sep 2020 18:50:02 #55 |

RSS feed for this topic

Reply

You must log in to post.