My Humax Forum » Freeview HD » HDR 1800T, 2000T

Topic — Add New » Read
Video Sender & HDR-2000T (5 years ago, 1 posts, 553 views)
Started by: Sue with no replies
latest post by
Sue
5 years ago
Recording conflict resolution at run-time (5 years ago, 2 posts, 775 views)
Started by: BryS with 2 posters
latest post by
grahamlthompson
5 years ago
Humax 2000T slow to respond on power up (5 years ago, 17 posts, 5145 views)
Started by: sparky with 9 posters
latest post by
Luke
5 years ago
Reordering folders and Streaming. (5 years ago, 2 posts, 840 views)
Started by: AndyMcH with 2 posters
latest post by
Owen Smith
5 years ago
ANOTHER HDR 2000T QUESTION (5 years ago, 5 posts, 774 views)
Started by: demto with 3 posters
latest post by
Owen Smith
5 years ago
No picture at start up (5 years ago, 1 posts, 635 views)
Started by: Marvin with no replies
latest post by
Marvin
5 years ago
Humax HDR-2000T remote (5 years ago, 4 posts, 1850 views)
Started by: gran with 2 posters
latest post by
Barry
5 years ago
Radio Screen Saver (5 years ago, 8 posts, 1779 views)
Started by: Davegg with 4 posters
latest post by
Davegg
5 years ago
Subtitles on BBC Three HD and BBC Four HD (5 years ago, 28 posts, 4351 views)
Started by: JamesB with 7 posters
latest post by
JamesB
5 years ago
Remote Range?? (5 years ago, 3 posts, 912 views)
Started by: philthfc with 3 posters
latest post by
Biggles
5 years ago
poor receiver performance (5 years ago, 15 posts, 3195 views)
Started by: Electronic Battle with 7 posters
latest post by
Owen Smith
5 years ago
DLNA compatibility with PS3? (5 years ago, 4 posts, 749 views)
Started by: tttonyyy with 2 posters
latest post by
grahamlthompson
5 years ago
Xbox One Support (5 years ago, 7 posts, 3376 views)
Started by: grunger with 3 posters
latest post by
grunger
5 years ago
TRUTH TABLE for front panel lamp (5 years ago, 2 posts, 948 views)
Started by: Marmaduke with 2 posters
latest post by
Marvin
5 years ago
Upgrade thoughts (5 years ago, 2 posts, 799 views)
Started by: Marvin with 2 posters
latest post by
JamesB
5 years ago
Stuck on Connecting… (5 years ago, 6 posts, 1925 views)
Started by: Gil with 4 posters
latest post by
CMoor
5 years ago
My loopthrough works in STANDBY (5 years ago, 11 posts, 1808 views)
Started by: Marmaduke with 5 posters
latest post by
JamesB
5 years ago
My new 2000T (5 years ago, 7 posts, 2009 views)
Started by: dalek with 3 posters
latest post by
dalek
5 years ago
Disappointed with the User Interface (5 years ago, 6 posts, 994 views)
Started by: Marmaduke with 5 posters
latest post by
grahamlthompson
5 years ago
Pink screen (5 years ago, 6 posts, 1593 views)
Started by: CarolAnn with 4 posters
latest post by
CarolAnn
5 years ago

New Topic in this Forum

You must log in to post.