My Humax Forum » Freesat HD » HDR 1000, 1010, 1100S

Topic — Add New » Read
  What can I record and watch using 1 or 2 cables (8 years ago, 1 posts, 4985 views)
Started by: grahamlthompson with no replies
latest post by
grahamlthompson
8 years ago
1100S - both tuners falsely show 'no signal' (2 weeks ago, 33 posts, 413 views)
Started by: Nanteos with 3 posters
latest post by
grahamlthompson
16 hours ago
  Humax hdr-1100s how to delete channels (3 days ago, 15 posts, 85 views)
Started by: Coupy with 5 posters
latest post by
Barry
2 days ago
Sorry, no internet connection found (5 days ago, 21 posts, 155 views)
Started by: tony1902 with 4 posters
latest post by
tony1902
3 days ago
Loss of Freesat Signal on HDR-1000S (4 days ago, 8 posts, 81 views)
Started by: totnesdave with 3 posters
latest post by
REPASSAC
4 days ago
Incorrect orientation (1 week ago, 1 posts, 48 views)
Started by: pewe with no replies
latest post by
pewe
1 week ago
"On Demand is loading" but it doesn't complete (2 weeks ago, 7 posts, 115 views)
Started by: Justintime with 3 posters
latest post by
Justintime
1 week ago
Subtitles on playback going out of sync (2 years ago, 15 posts, 1729 views)
Started by: Hammy with 5 posters
latest post by
Dodie117
1 week ago
On Demand not working on HDR1100S (1 mnth ago, 19 posts, 355 views)
Started by: Leec with 7 posters
latest post by
Barry
3 weeks ago
1010S Sound Issue - Very Muffled/Hardly Audible (3 weeks ago, 5 posts, 95 views)
Started by: Hoops with 3 posters
latest post by
Barry
3 weeks ago
HDR 1100S No signal to TV via HDMI (1 mnth ago, 1 posts, 60 views)
Started by: naskew with no replies
latest post by
naskew
1 mnth ago
HDR 1100s remote control not working. (4 years ago, 34 posts, 41618 views)
Started by: JP27 with 20 posters
latest post by
naskew
1 mnth ago
My 1010s is not recording (1 mnth ago, 7 posts, 162 views)
Started by: denbo007 with 5 posters
latest post by
REPASSAC
1 mnth ago
1010S continually rebooting (2 mnths ago, 5 posts, 184 views)
Started by: VFRRider750 with 2 posters
latest post by
VFRRider750
1 mnth ago
Humax 1100s problems? (1 mnth ago, 3 posts, 148 views)
Started by: foxleybob with 3 posters
latest post by
REPASSAC
1 mnth ago
Some channels not receiving a signal (1 mnth ago, 9 posts, 144 views)
Started by: Rachel90 with 3 posters
latest post by
Rachel90
1 mnth ago
net usage (1 mnth ago, 4 posts, 96 views)
Started by: tv-tony with 3 posters
latest post by
Luke
1 mnth ago
Audio output via HDMI to TV is very low (1 mnth ago, 42 posts, 529 views)
Started by: Justintime with 3 posters
latest post by
SSThing
1 mnth ago
Listing programs by genre ? (1 mnth ago, 1 posts, 49 views)
Started by: softfoot with no replies
latest post by
softfoot
1 mnth ago
HDR-1000S just powering itself off (8 years ago, 6 posts, 3713 views)
Started by: Nesbitt with 4 posters
latest post by
fm49218
1 mnth ago
Has Humax a future with 4K? (2 mnths ago, 8 posts, 197 views)
Started by: cerclebois with 4 posters
latest post by
grahamlthompson
2 mnths ago

New Topic in this Forum

You must log in to post.