My Humax Forum » Freesat HD » HDR 1000, 1010, 1100S

Topic — Add New » Read
  What can I record and watch using 1 or 2 cables (6 years ago, 1 posts, 4564 views)
Started by: grahamlthompson with no replies
latest post by
grahamlthompson
6 years ago
4K tV? (1 week ago, 17 posts, 271 views)
Started by: foxleybob with 6 posters
latest post by
foxleybob
1 day ago
Power settings (1 day ago, 4 posts, 56 views)
Started by: Roger99 with 3 posters
latest post by
Roger99
1 day ago
Humax HDR1010S - 1TB - Won't record (1 week ago, 8 posts, 167 views)
Started by: BC with 3 posters
latest post by
grahamlthompson
2 days ago
HDR 1000s dropping out of 1080p to 576i on start (1 year ago, 21 posts, 1017 views)
Started by: peteBro with 4 posters
latest post by
Paul Bton
6 days ago
Dormant account removal (1 week ago, 10 posts, 187 views)
Started by: Filshine with 5 posters
latest post by
Trev
6 days ago
Humax 1100 (1 week ago, 3 posts, 73 views)
Started by: ValG with 3 posters
latest post by
Martin Liddle
1 week ago
Missing Sound on HD Channels (2 weeks ago, 4 posts, 157 views)
Started by: Davelehuray with 3 posters
latest post by
grahamlthompson
2 weeks ago
How can I change a default channel? (2 weeks ago, 6 posts, 93 views)
Started by: Calomax with 2 posters
latest post by
Calomax
2 weeks ago
HDR1000S dead - any known fixes now? (3 weeks ago, 7 posts, 252 views)
Started by: wards242 with 3 posters
latest post by
wards242
2 weeks ago
Cheap 2nd-hand box? (3 weeks ago, 2 posts, 109 views)
Started by: Hogweed with no replies
latest post by
Hogweed
3 weeks ago
Humax HDR-1100S WiFi Antenna location (4 weeks ago, 1 posts, 66 views)
Started by: Justintime with no replies
latest post by
Justintime
4 weeks ago
HDR 1000 slow when networked (1 mnth ago, 28 posts, 478 views)
Started by: Hogweed with 5 posters
latest post by
Hogweed
1 mnth ago
Internet browser? (1 mnth ago, 1 posts, 86 views)
Started by: foxleybob with no replies
latest post by
foxleybob
1 mnth ago
Newbie (1 mnth ago, 13 posts, 217 views)
Started by: foxleybob with 4 posters
latest post by
foxleybob
1 mnth ago
Programmes not recording on a 1000S (3 years ago, 15 posts, 1000 views)
Started by: nsjallan with 4 posters
latest post by
aerv74
1 mnth ago
Copying Humax content to an external HDD and back (1 mnth ago, 10 posts, 212 views)
Started by: affpuddledave with 3 posters
latest post by
Martin Liddle
1 mnth ago
Hard drive issues (3 years ago, 619 posts, 67846 views)
Started by: ChrisSquires with 102 posters
latest post by
hairbear
1 mnth ago
myhumax.net not working on HDR-1000S? (1 mnth ago, 1 posts, 94 views)
Started by: boodysaspie with no replies
latest post by
boodysaspie
1 mnth ago
HDR1000S - startup screen display bug (1 mnth ago, 5 posts, 170 views)
Started by: keble6 with 2 posters
latest post by
grahamlthompson
1 mnth ago
HDR-1000S loss of audio from HDMI port (1 mnth ago, 2 posts, 90 views)
Started by: grahamlthompson with no replies
latest post by
grahamlthompson
1 mnth ago

New Topic in this Forum

You must log in to post.