My Humax Forum » Freeview SD » PVR 9150T, 9200T, 9300T

Topic — Add New » Read
  The 9200 --:-- clock problem. (9 years ago, 56 posts, 23887 views)
Started by: Biggles with 23 posters
latest post by
Biggles
1 year ago
  Remote control has stopped working - unit failing to respond. (8 years ago, 371 posts, 108290 views)
Started by: wheatey with 98 posters
latest post by
BrunoMills
2 years ago
Loss of sound query (3 days ago, 2 posts, 48 views)
Started by: Chorlton with no replies
latest post by
Chorlton
2 days ago
RCA to HDMI (1 week ago, 3 posts, 56 views)
Started by: fluffy54 with 2 posters
latest post by
fluffy54
6 days ago
PVR recommendations with Scart and HDMI inputs (1 week ago, 13 posts, 186 views)
Started by: Chorlton with 5 posters
latest post by
Chorlton
1 week ago
Lost the 'Record' option on Humax PVR 9300T (1 week ago, 5 posts, 96 views)
Started by: Chorlton with 3 posters
latest post by
Chorlton
1 week ago
Picture and sound jumping on some recordings (2 years ago, 20 posts, 3997 views)
Started by: Jack333 with 10 posters
latest post by
NhOldBoy
1 week ago
Humax PVR-9200 (1 mnth ago, 28 posts, 564 views)
Started by: Hussyboy with 6 posters
latest post by
Hussyboy
4 weeks ago
PVR9300T (1 mnth ago, 7 posts, 176 views)
Started by: 6stoke with 3 posters
latest post by
Trev
1 mnth ago
Humax PVR 9300t (2 mnths ago, 6 posts, 132 views)
Started by: Sarah Lewis with 3 posters
latest post by
Luke
2 mnths ago
Humax PVR 9300t (2 mnths ago, 1 posts, 74 views)
Started by: Sarah Lewis with no replies
latest post by
Sarah Lewis
2 mnths ago
PVR 9300 (3 mnths ago, 6 posts, 148 views)
Started by: tv-tony with 3 posters
latest post by
tv-tony
3 mnths ago
9300-T : Strange recording behaviour (1 year ago, 14 posts, 647 views)
Started by: Daf with 2 posters
latest post by
Daf
3 mnths ago
Old PVR 9150T (4 mnths ago, 21 posts, 411 views)
Started by: Sarahj0nes with 6 posters
latest post by
Trev
4 mnths ago
PVR 9150T Using Humaxrw in Linux (5 mnths ago, 17 posts, 614 views)
Started by: dave2319 with 4 posters
latest post by
Martin Liddle
5 mnths ago
Recorded programmes disappeared (6 mnths ago, 18 posts, 496 views)
Started by: Patrick1 with 4 posters
latest post by
Martin Liddle
5 mnths ago
9300t (6 mnths ago, 3 posts, 247 views)
Started by: iron duke with 3 posters
latest post by
Luke
6 mnths ago
Picture settings lost on standby (8 mnths ago, 9 posts, 312 views)
Started by: batteryman with 3 posters
latest post by
batteryman
7 mnths ago
Pictures keep breaking up (8 mnths ago, 3 posts, 200 views)
Started by: blueman with 3 posters
latest post by
Martin Liddle
8 mnths ago
Pvr 9300t update (9 mnths ago, 5 posts, 339 views)
Started by: Caroline Standh with 3 posters
latest post by
Caroline Standh
9 mnths ago
humax pvr 9200t old software (9 mnths ago, 16 posts, 637 views)
Started by: middz with 6 posters
latest post by
Biggles
9 mnths ago
Connecting 9150T to New TV (9 mnths ago, 4 posts, 359 views)
Started by: DJC969 with 3 posters
latest post by
Martin Liddle
9 mnths ago

New Topic in this Forum

You must log in to post.